Bigdecimal-1.3.2 not built


(Brian Kai) #1

I just upgraded to Mojave (as well as the new command line tools) and Brew is now giving me the following error:

Ignoring bigdecimal-1.3.2 because its extensions are not built. Try: gem pristine bigdecimal --version 1.3.2

I’ve tried the suggestion without success but I also noticed that I do not have 1.3.2 installed… instead I have 1.3.5. How do I get Brew to see the update and use that instead… or at least squash that error?

I’ve also tried un/re-installing bundler.


(Sean Molenaar) #2

There are some solutions reported here: https://github.com/Homebrew/brew/issues/4975


#3

I could not find a solution in the issue linked. Is there a confirmed approach that resolved this issue?


(Brian Kai) #4

Not that I’ve found, I’m watching the thread Sean linked and here. I’ve tried all of those suggestions already with no success.


(Zj299792458) #5

try:
sudo gem uninstall bigdecimal --version 1.3.2


(Brian Kai) #6

Already tried that. From the other thread it sounds like an issue with Homebrew’s integrated ruby. I’ve even tried downgrading to 1.3.2, so it was obviously there but Homebrew wouldn’t see it. As far as I can tell, however, this is only an annoyance as everything seems to work regardless of the error.


(Zj299792458) #7

If you install another ruby from Homebrew instead of the Mac OS Built-in ruby, this will be complicated. (Homebrew doesn’t come with integrated ruby by default)</del.>

Corrected: Homebrew does ship with built in ruby


(Luis Davim) #8

Homebrew does seem to use it’s own embedded portable-ruby, look here:

$ ps aux | grep brew
ldavim           48101   8.6  0.7  4459820 110236 s002  S+    1:07PM   0:25.79 
/usr/local/Homebrew/Library/Homebrew/vendor/portable-ruby/current/bin/ruby -W0 
/usr/local/Homebrew/Library/Homebrew/brew.rb cask reinstall chefdk
ldavim           69856   0.0  0.0  4268036    812 s003  S+    1:11PM   0:00.00 grep --color=auto brew

(Sean Molenaar) #9

Homebrew does ship with a ruby version. This allows brew to bypass the ancient bugs apple ships :slight_smile:


(Zj299792458) #10

@luisdavim
@SMillerDev

Sorry, Thank you for correcting me! :+1:


#11

I got it fixed by following these steps: